Photoshop CS6 Compatibility

The latest versions of all of our currently shipping products are compatible with Photoshop CS6. If an old installer can’t find Photoshop CS6 then get the latest installer from our web site.

Note that you don’t need to save old installers or CDs. The most up to date installers can always be found on our web site.

About Jeff

Jeff Butterworth is the founder of Alien Skin Software. He used to create the products, but now he does marketing and gets coffee for the programmers.
This entry was posted in Alien Skin Software, Announcements, Blow Up, Bokeh, Exposure, Eye Candy, Snap Art and tagged . Bookmark the permalink.

21 Responses to Photoshop CS6 Compatibility

  1. Hi Jeff,
    Now that I have the PS CS6 installed — can I get my Alien Skin Exposure 3 to work with that?
    Thanks in advance
    Best
    Anders

  2. James Faulconer says:

    Can Exposure 4 be used on video in Photoshop CS6 Extended? I have some need to apply the old film filters to video as well as photographs and am hoping it can do both.

  3. Brett Dawson says:

    I’m trying to re-install my Eyecandy 6 after rebuilding my Mac – It installs fine, but when it tries to launch the ‘Licence Activation Tool.app’, I get a warning that says ‘Fatal error occurred while starting the application. (1002)’ hence, I can’t fill in my licence code.

    Anyone else having this problem, and is there a workaround?

  4. Carol Finsand says:

    Since upgrading to OS Mt. Lion on my mac I can’t seem to get Blow-up to work correctly. It stops short of enlarging everything, leaving some layers original size.
    I’m using CS5. Is there an update for Mt. Lion?

  5. Felix Bünning says:

    Is there any way to get Exposure 2 running with PS CS6?

  6. Scott Morris says:

    I just go Photoshop CS6 for PC . Can I install my old version of Exposure 1 ?

    • Robert says:

      Exposure 1 is not supported in CS6. You are more than welcome to try performing a custom install, installing it directly into the CS6 plug-ins folder, but we will not be able to assist with any problem. The best option is to upgrade to Exposure 4. If you have any further questions, please email us at Support@alienskin.com.

  7. Tito Z says:

    Can Eye Candy 5 be used with Photoshop CS6?

  8. Amina Zaher says:

    Hi Flex,

    I’m a new user and unable to download the software, i have PS6 on Mac and want to download Alien SKin 4 Exposure 4.
    Each time i visit http://www.alienskin.com/downloads I can’t find any download bottom?

    Please advise.

  9. Samrat says:

    I tried to permanently delete the downloaded trail version of Exposure 5 from my CS5 following the path Application/ Adobe Photoshop CS5/ Plugins/ Alien Skin, but to my surprise it still shows in the the effects window. Can you suggest me a solution to this. Thank you.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Heads up! You are attempting to upload an invalid image. If saved, this image will not display with your comment.