Check your version of Eye Candy 6

If you use Eye Candy 6 then please check your version number in the about box. On Windows, start Eye Candy 6 and open the Help menu to find the about box. On a Mac, start Eye Candy 6 and then go to the Photoshop menu to find the about box.

If your Eye Candy 6 version is not 6.1.1.1058 or newer then you need to throw away your old installers and download the latest Windows or Mac version of Eye Candy 6.

Older versions use our old activation system which will stop working for Eye Candy 6 on May 21st, 2012.  Eye Candy 6 won’t immediately die, but you won’t be able to do a new installation and activate it.

If Eye Candy 6 is working for you then you don’t need to reinstall. But if it ever gives you any trouble (like activation errors) then uninstall the old version and run that new installer. Instructions for uninstalling are below.

Uninstall from Windows

Uninstall from Mac

 

This entry was posted in Announcements, Eye Candy and tagged . Bookmark the permalink.

11 Responses to Check your version of Eye Candy 6

  1. Jim Fleming says:

    I received notification via my Eye Candy 6 that I need to throw away my old installers. Please tell me how to do this and how do I reinstall Eye Candy 6 once I delete it via Windows 7 uninstall program feature.

    Thanks,

    Jim

  2. Alice says:

    I have verison 5.. is there an upgrade link?

  3. Bill Proctor says:

    I just upgraded to CS6, and have successfully upgraded and installed Eye Candy 6,
    Image Doctor 2 and Blowup 2. I also have Eye Candy 5 – Impact. Is it compatible with CS6?
    and can it be upgraded? ANd if so, how do I get it – it’s not listed on your site.

  4. Denise says:

    I just purchased a new computer and have been trying to install Eye Candy 6. I cannot get it to show up in Corel PaintShop Pro X4 at all .. Ive place it in several diff folders … added a link to those folders within PSP and nothing … no eye candy showing up in my list of plug ins … I dont know what else to try.

  5. Denise says:

    Ok I did some more research online and even tho i have a 64 bit system they suggested to someone else to install the 32 bit as well .. once i did that it works …. no way to explain that one tho lol.

    • Matt says:

      Glad you found the answer. The 32-bit version of Eye Candy 6 is the only one that will work with Corel. If you have any other problems, you can hit the Support link to enter a ticket and we’ll get right back to you.

  6. Clyde Wittsell says:

    I had brought my Eye Candy Bundle package 5 on e-bay, I did not receive the disk to it, and downloaded it from the internet. Now that I have gone and purchased a new computer, I have no way to retrieve my Eye Candy from my old computer. I am using Photoshop Elements 7 any help in being able to purchase the program once again? My new computer is running windows 7, will I have to upgrade to Eye Candy Package 6 and if so, will 6 do the same as my bundle package 5 did??

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Heads up! You are attempting to upload an invalid image. If saved, this image will not display with your comment.